summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-16 00:44:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-25 16:35:51 +0200
commit3d39145d00d172b5bc09357f34c495aef80177ca (patch)
tree0c9dd06e1aa93385356ae489ef6baaf07972b69f /dev-qt
parentdev-qt/qtimageformats: 5.15.2-r10 version bump at KDE cb82c743 (diff)
downloadgentoo-3d39145d00d172b5bc09357f34c495aef80177ca.tar.gz
gentoo-3d39145d00d172b5bc09357f34c495aef80177ca.tar.bz2
gentoo-3d39145d00d172b5bc09357f34c495aef80177ca.zip
dev-qt/qtlocation: 5.15.2-r10 version bump at KDE 861e372b
EAPI-8 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index d6548eb5847d..2cf39e97ff8e 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1 +1,2 @@
+DIST qtlocation-5.15.2-861e372b.tar.gz 5431120 BLAKE2B c66e81f7e726b53000a0f8a4eafa9a4a6168aa08c89d4d0e2ef11b02e3598fd0b3f30dbd21e6c5436814bb88fa69c96d141b0d0d79f13239ec61396269af089a SHA512 b7cac8cd42185504c6140f1dcd4e8c0c749e3d8f22bf9977e97268e0ad6fbd3733e571a255ab7824eba31e30e707e804b07317f2ec9b7be15a4a5756c78c9e41
DIST qtlocation-everywhere-src-5.15.2.tar.xz 6556764 BLAKE2B a322f35ece266fff6428da9090f02c0d5749a4750ff0655ef09695f147d88d667b5917335e44d0f8721cc56f425c171fb11d0f34342aff005327518e9c1d6db8 SHA512 6192922506b3ea354e85431df83c19d7cc9aebb17549c6a1de48f625bf8365ff3db3161080dde254a5fb9199d99c3c5dc8e1533429150be55df96ddb7d6ce16f
diff --git a/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild b/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
new file mode 100644
index 000000000000..f5324144a067
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=861e372b6ad81570d4f496e42fb25a6699b72f2f
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}