summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-16 00:46:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-25 16:35:51 +0200
commit3df377295a8d6d5b42a10ab2e03a6ffbb10e5b03 (patch)
tree7c80343e9dca8eafc997c2f1090b2290f6ed4893 /dev-qt
parentdev-qt/qtvirtualkeyboard: 5.15.2-r10 version bump at KDE 2f0e9f98 (diff)
downloadgentoo-3df377295a8d6d5b42a10ab2e03a6ffbb10e5b03.tar.gz
gentoo-3df377295a8d6d5b42a10ab2e03a6ffbb10e5b03.tar.bz2
gentoo-3df377295a8d6d5b42a10ab2e03a6ffbb10e5b03.zip
dev-qt/qtwayland: 5.15.2-r10 version bump at KDE d4c41797
EAPI-8 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r10.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index d2833c8905df..856cb35413b6 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
+DIST qtwayland-5.15.2-d4c41797.tar.gz 829183 BLAKE2B 2a185e724dc4bb409d588664adf956fc16ab2115f5f2a5217c7654312f320402ef5b247aae44ec021c274b2a070698b2e6771135d604baf8308d8d33deffc55f SHA512 2e8e6149f6ffd5379075c235ea334aac0663e1c888291a564467c46f8073503d6b6c3c0cf9080cfa98c1d8742a6295c9b9aff877afcf06e8efccd0b54b1b9389
DIST qtwayland-everywhere-src-5.15.2.tar.xz 564884 BLAKE2B 472effd3e9f3fd5470e0449703a52d45f2fd823770880b5ad15d8bf99196eee5d8511ca2bc9e23df6e27c933551d1853928ba79b4b1e5fa6e53334c54c04a463 SHA512 e8657ed676873da7b949e6a1605d025918a03336af9c68f32741945ec3c71a604def55bb00737ba4d97b91c00d0e2df1a83cdcedcf5795c6b2a1ef2caa21c91c
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r10.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r10.ebuild
new file mode 100644
index 000000000000..a93d716f58e2
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2-r10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=d4c41797b61a5a8da47c5821711aca72e756dcbf
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ ~dev-qt/qtcore-${PV}:5=
+ ~dev-qt/qtdeclarative-${PV}:5=
+ ~dev-qt/qtgui-${PV}:5=[egl,libinput,vulkan=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ ~dev-qt/qtgui-${PV}[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}