summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-23 00:23:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-25 16:35:52 +0200
commit61e8838aaf1f6351bddf2109c9f7a919cd5d7479 (patch)
tree2c514d72be2fc1ca6ebd2c1417e13934410ff23f /dev-qt
parentdev-qt/qtspeech: EAPI-8 bump, add IUSE=flite (diff)
downloadgentoo-61e8838aaf1f6351bddf2109c9f7a919cd5d7479.tar.gz
gentoo-61e8838aaf1f6351bddf2109c9f7a919cd5d7479.tar.bz2
gentoo-61e8838aaf1f6351bddf2109c9f7a919cd5d7479.zip
dev-qt/qdoc: Add dev-qt/qtxml to DEPEND
- EAPI-8 - Drop dev-qt/qtchooser from RDEPEND Closes: https://bugs.gentoo.org/802492 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qdoc/qdoc-5.15.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-qt/qdoc/qdoc-5.15.2-r1.ebuild b/dev-qt/qdoc/qdoc-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..09d86b11c1d4
--- /dev/null
+++ b/dev-qt/qdoc/qdoc-5.15.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt documentation generator"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}:5=
+ sys-devel/clang:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+# TODO: we know it is bogus, figure out how to disable checks, bug 802492
+DEPEND="${RDEPEND}
+ ~dev-qt/qtxml-${PV}
+"
+
+src_prepare() {
+ qt_use_disable_mod qml qmldevtools-private \
+ src/qdoc/qdoc.pro
+
+ qt5-build_src_prepare
+}