summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-28 08:28:31 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-28 09:07:41 -0500
commit8c975b160438b166ceae2d7d0f3b87d1934c723f (patch)
tree8ff22c5f3e7bbe0d8643867b5251a832a01fa18a /dev-qt
parentkde-frameworks/oxygen-icons: add 6.0.0 (diff)
downloadgentoo-8c975b160438b166ceae2d7d0f3b87d1934c723f.tar.gz
gentoo-8c975b160438b166ceae2d7d0f3b87d1934c723f.tar.bz2
gentoo-8c975b160438b166ceae2d7d0f3b87d1934c723f.zip
dev-qt/qtserialbus: new slot, add 6.6.2:6 + live
Nothing special (same as Qt5) and tests pass.. albeit it does need extras to cleanup junk it installs when tests are enabled. It would be possible to make qtserialport optional by using cmake_use_find_package but unsure how much sense this makes. Given Qt5 didn't, not going to bother unless someone using this package actually wants to skip this dependency. Note that this has no revdeps neither for Qt5 nor Qt6, but some users apparently need it and the package itself is simple. Closes: https://bugs.gentoo.org/925517 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtserialbus/Manifest1
-rw-r--r--dev-qt/qtserialbus/qtserialbus-6.6.2.ebuild33
-rw-r--r--dev-qt/qtserialbus/qtserialbus-6.6.9999.ebuild33
-rw-r--r--dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild33
-rw-r--r--dev-qt/qtserialbus/qtserialbus-6.9999.ebuild33
5 files changed, 133 insertions, 0 deletions
diff --git a/dev-qt/qtserialbus/Manifest b/dev-qt/qtserialbus/Manifest
index 906d81e979f4..b25580a9f596 100644
--- a/dev-qt/qtserialbus/Manifest
+++ b/dev-qt/qtserialbus/Manifest
@@ -1 +1,2 @@
DIST qtserialbus-everywhere-opensource-src-5.15.12.tar.xz 359492 BLAKE2B b27e5e26e7c881602dfcd6daf287ae3d7f52011abe78303e51119242e550d73c8d11c259ddd96f067aebb6d19602e996ddebe46fe7ab87fc0938a167e2e20caa SHA512 d6571b6d54fe91ff945c0bd51bcecb97ae3d001ee3e1f30deb042a52bab17ad7e059ae943c0a3f2a4d6e7a952cb3f68b71275cef0fda1875fd233c8dc17d0d3c
+DIST qtserialbus-everywhere-src-6.6.2.tar.xz 545828 BLAKE2B 27e9f44c68d34c9573218824ba8793388574f05fdb2cb4f271c6955d3cfd596612b8b2ed041b861b13b59e5fd54ee44f9b70d922b6b9661e81634028f827c94c SHA512 d21c1c95b7dc495f2d963af7e0e927265573d5d0ff163ee51e19c0a62486ba78b8769ba65f7e196116fa0d029db78e6a453c3bde8a3c7f4447a278bde4de87be
diff --git a/dev-qt/qtserialbus/qtserialbus-6.6.2.ebuild b/dev-qt/qtserialbus/qtserialbus-6.6.2.ebuild
new file mode 100644
index 000000000000..83df0a8835c0
--- /dev/null
+++ b/dev-qt/qtserialbus/qtserialbus-6.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module to access CAN, ModBus, and other industrial serial buses and protocols"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtserialport-${PV}:6
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6SerialBus/*TestCanBusPlugin*.cmake
+ "${D}${QT6_MKSPECSDIR}"/modules/qt_plugin_qttestcanbus.pri
+ "${D}${QT6_PLUGINDIR}"/canbus/libqttestcanbus.*
+ "${D}${QT6_PLUGINDIR}"/canbus/objects-*/
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtserialbus/qtserialbus-6.6.9999.ebuild b/dev-qt/qtserialbus/qtserialbus-6.6.9999.ebuild
new file mode 100644
index 000000000000..83df0a8835c0
--- /dev/null
+++ b/dev-qt/qtserialbus/qtserialbus-6.6.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module to access CAN, ModBus, and other industrial serial buses and protocols"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtserialport-${PV}:6
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6SerialBus/*TestCanBusPlugin*.cmake
+ "${D}${QT6_MKSPECSDIR}"/modules/qt_plugin_qttestcanbus.pri
+ "${D}${QT6_PLUGINDIR}"/canbus/libqttestcanbus.*
+ "${D}${QT6_PLUGINDIR}"/canbus/objects-*/
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild b/dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild
new file mode 100644
index 000000000000..83df0a8835c0
--- /dev/null
+++ b/dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module to access CAN, ModBus, and other industrial serial buses and protocols"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtserialport-${PV}:6
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6SerialBus/*TestCanBusPlugin*.cmake
+ "${D}${QT6_MKSPECSDIR}"/modules/qt_plugin_qttestcanbus.pri
+ "${D}${QT6_PLUGINDIR}"/canbus/libqttestcanbus.*
+ "${D}${QT6_PLUGINDIR}"/canbus/objects-*/
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtserialbus/qtserialbus-6.9999.ebuild b/dev-qt/qtserialbus/qtserialbus-6.9999.ebuild
new file mode 100644
index 000000000000..83df0a8835c0
--- /dev/null
+++ b/dev-qt/qtserialbus/qtserialbus-6.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module to access CAN, ModBus, and other industrial serial buses and protocols"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtserialport-${PV}:6
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6SerialBus/*TestCanBusPlugin*.cmake
+ "${D}${QT6_MKSPECSDIR}"/modules/qt_plugin_qttestcanbus.pri
+ "${D}${QT6_PLUGINDIR}"/canbus/libqttestcanbus.*
+ "${D}${QT6_PLUGINDIR}"/canbus/objects-*/
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}