summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-07-17 23:18:56 +0800
committerYixun Lan <dlan@gentoo.org>2021-07-18 06:45:21 +0800
commit980dc7e8d6fd082c77650dc05051af0f7e1b8b3a (patch)
treeb78aeed1c1ae80837ff3a15b1ca7bd5771c8c0d0 /dev-qt
parentbase/package.use.stable.mask: add x11-wm/xpra[doc] (diff)
downloadgentoo-980dc7e8d6fd082c77650dc05051af0f7e1b8b3a.tar.gz
gentoo-980dc7e8d6fd082c77650dc05051af0f7e1b8b3a.tar.bz2
gentoo-980dc7e8d6fd082c77650dc05051af0f7e1b8b3a.zip
dev-qt/qtdeclarative: riscv: fix missing atomic library
this will workaroud the error when build in ARCH=riscv, tested with gcc-11 A likely better fix is to have qtcore detect the need for -latomic at configure time and, if needed, link to it Bug: https://bugs.gentoo.org/790689 Closes: https://github.com/gentoo/gentoo/pull/21689 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtdeclarative/files/qtdeclarative-5.15.2-riscv-atomic.patch12
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-qt/qtdeclarative/files/qtdeclarative-5.15.2-riscv-atomic.patch b/dev-qt/qtdeclarative/files/qtdeclarative-5.15.2-riscv-atomic.patch
new file mode 100644
index 000000000000..a619f3db833c
--- /dev/null
+++ b/dev-qt/qtdeclarative/files/qtdeclarative-5.15.2-riscv-atomic.patch
@@ -0,0 +1,12 @@
+diff --git a/src/qml/qml.pro b/src/qml/qml.pro
+index 7d5a92a..01f3b79 100644
+--- a/src/qml/qml.pro
++++ b/src/qml/qml.pro
+@@ -19,6 +19,7 @@ solaris-cc*:QMAKE_CXXFLAGS_RELEASE -= -O2
+
+ # Ensure this gcc optimization is switched off for mips platforms to avoid trouble with JIT.
+ gcc:isEqual(QT_ARCH, "mips"): QMAKE_CXXFLAGS += -fno-reorder-blocks
++gcc:isEqual(QT_ARCH, "riscv64"): LIBS += -latomic
+
+ DEFINES += QT_NO_FOREACH
+
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild
index ccbde5b669ef..6b32fc222cd3 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.14.2-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
"${FILESDIR}/${P}-gcc11.patch" # bug 752093
+ "${FILESDIR}/${P}-riscv-atomic.patch" #bug 790689
)
src_prepare() {