summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorDenis Pronin <dannftk@yandex.ru>2022-04-15 07:32:05 +0300
committerSam James <sam@gentoo.org>2022-04-15 07:08:30 +0100
commitb21c0ff832622375a6aae8b36c6a0566e6dfaf1c (patch)
tree9b5a0084e2f018ae29ce00e95fc37111e18a0bf7 /dev-qt
parentnet-im/telegram-desktop: Fix building with KWayland 5.93 (diff)
downloadgentoo-b21c0ff832622375a6aae8b36c6a0566e6dfaf1c.tar.gz
gentoo-b21c0ff832622375a6aae8b36c6a0566e6dfaf1c.tar.bz2
gentoo-b21c0ff832622375a6aae8b36c6a0566e6dfaf1c.zip
dev-qt/qtwayland: fixed building with clang (missing include)
Added qtwayland-5.15.3-clang.patch that fixes building with clang (libcxx). Closes: https://bugs.gentoo.org/833488 Closes: https://github.com/gentoo/gentoo/pull/25030 Signed-off-by: Denis Pronin <dannftk@yandex.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.15.3-clang.patch12
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.3-r1.ebuild5
2 files changed, 16 insertions, 1 deletions
diff --git a/dev-qt/qtwayland/files/qtwayland-5.15.3-clang.patch b/dev-qt/qtwayland/files/qtwayland-5.15.3-clang.patch
new file mode 100644
index 000000000000..4ad80127f516
--- /dev/null
+++ b/dev-qt/qtwayland/files/qtwayland-5.15.3-clang.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/833488
+--- a/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
++++ b/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
+@@ -44,6 +44,8 @@
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
+
++#include <array>
++
+ // compatibility with libdrm <= 2.4.74
+ #ifndef DRM_FORMAT_RESERVED
+ #define DRM_FORMAT_RESERVED ((1ULL << 56) - 1)
diff --git a/dev-qt/qtwayland/qtwayland-5.15.3-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.15.3-r1.ebuild
index 4743cce364a5..2c07d29ec9f6 100644
--- a/dev-qt/qtwayland/qtwayland-5.15.3-r1.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.15.3-r1.ebuild
@@ -33,7 +33,10 @@ BDEPEND="
dev-util/wayland-scanner
"
-PATCHES=( "${FILESDIR}/${PN}-5.15.2-QTBUG-90037-QTBUG-91264.patch" ) # upstream pending
+PATCHES=(
+ "${FILESDIR}/${PN}-5.15.2-QTBUG-90037-QTBUG-91264.patch" # upstream pending
+ "${FILESDIR}/${PN}-5.15.3-clang.patch"
+)
src_configure() {
local myqmakeargs=(