summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-16 14:52:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-08 00:38:49 +0100
commitb4766d8df05d3c6fa584a6b81f684cb51568227e (patch)
tree58fffb1e0ba1bd76cdbc52879836fee773bb8713 /dev-qt
parentprofiles/base: mask USE=jemalloc for ~mail-filter/rspamd-3.1 (diff)
downloadgentoo-b4766d8df05d3c6fa584a6b81f684cb51568227e.tar.gz
gentoo-b4766d8df05d3c6fa584a6b81f684cb51568227e.tar.bz2
gentoo-b4766d8df05d3c6fa584a6b81f684cb51568227e.zip
dev-qt/qtwayland: 5.15.2-r15 version bump at KDE 992833ca
Add missing dep on dev-util/wayland-scanner. Upstream fixes: "Fix the logic for decoding modifiers map in Wayland text input protocol" QTBUG: https://bugreports.qt.io/browse/QTBUG-97094 "Wayland client: use wl_keyboard to determine active state" https://codereview.qt-project.org/c/qt/qtwayland/+/367306 Pre-requisite of fix in kde-frameworks/kio-5.88.0, see also: https://invent.kde.org/frameworks/kio/-/merge_requests/619 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=421974 "Client: do not empty clipboard when a new popup/window is opened" QTBUG: https://bugreports.qt.io/browse/QTBUG-93474 Thanks-to: Davide Pesavento <pesa@gentoo.org> Bug: https://bugs.gentoo.org/818997 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 3a2db5f35aa4..8fcb0883fb4a 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
+DIST qtwayland-5.15.2-992833ca.tar.gz 829101 BLAKE2B a00cce48b06b9537561e51598dceb3b2cf2f77ccba869b726b7ac473764dd64024ef759a8d46dd3f3e1161c27fcb1c70ce20a5c3d6f2e9938950cd38f84bc2c2 SHA512 3520a7b8b27703b3306a5e852498c1805f359e09d2622ed53b5ee2038e6e99d3d0132f47d78167cdf4a1d1f0d4955f8440cec897fcc4dc24f7d3a3a7a493c584
DIST qtwayland-5.15.2-efe6edca.tar.gz 829293 BLAKE2B 6ccc5a4e111818cc65855eb4570727f30932bec9a749069550d07332df719eaeec0baf472c025150a32c9c380294f5e9496ad3babd181887a02fc37d1bfd5f2a SHA512 87190cd1ade57c98da972a2f5d48aa0376ccc4bfa589f5832b8a62a63b3eafa6acf88d812ae98c484d4b02878ae2c1986c3759c0ba3f46894c76af713d7b8346
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild
new file mode 100644
index 000000000000..ea619cd58e78
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=992833ca741efe8f533c61abfaf129a1d8bfcfee
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+SLOT=5/${QT5_PV} # bug 815646
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}