summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-05 21:01:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-08 18:54:35 +0200
commite1c499d2119edac0b92ca6a033bd0c0e5b9628ea (patch)
tree3d45557c3cf7f439e99902961a5f9abf39486e5a /dev-qt
parentdev-qt/qdoc: 5.15.2-r10 version bump at KDE 33693a92 (diff)
downloadgentoo-e1c499d2119edac0b92ca6a033bd0c0e5b9628ea.tar.gz
gentoo-e1c499d2119edac0b92ca6a033bd0c0e5b9628ea.tar.bz2
gentoo-e1c499d2119edac0b92ca6a033bd0c0e5b9628ea.zip
dev-qt/assistant: 5.15.2-r10 version bump at KDE 33693a92
- EAPI-8 bump - switch from ~PV to =QT5_PV* version dependencies Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/assistant/Manifest1
-rw-r--r--dev-qt/assistant/assistant-5.15.2-r10.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index c9faaf55f594..2ad3df5c2a7f 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1 +1,2 @@
+DIST qttools-5.15.2-33693a92.tar.gz 12266718 BLAKE2B c519abdcca9df3b191297b859b2dce417ee9a79f9e3bcb3f2aa0017266b8edc855645108f5f7e6853d28f4c7507c92646ce8130731a345c6ffdfcd37fb1f4789 SHA512 9a62f1849c8eb65384d19de61cb6a08d1f467877181fd752e58b2b4e7d566c5d868c7ebab2d01591c6f540c01c705b7f8e0fe76c26cb0ee78f590ddae57048d2
DIST qttools-everywhere-src-5.15.2.tar.xz 8894728 BLAKE2B bbc57c58a43f827cfa04031f12d46d4d660456e4a5feabe17fdbb42126da06ed7031807fe963883d452fd1916330e94fcc66b9e9bb69ee4455a38bf3cbd80f5a SHA512 3bd32a302af6e81cd5d4eb07d60c5ef233f1ca7af1aae180c933ac28fafffce28c6c868eb032108747937ea951d6d4f0df5516841bc65d22c529207147533a8b
diff --git a/dev-qt/assistant/assistant-5.15.2-r10.ebuild b/dev-qt/assistant/assistant-5.15.2-r10.ebuild
new file mode 100644
index 000000000000..c1c5acadc774
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.2-r10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=33693a928986006d79c1ee743733cde5966ac402
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}