summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 11:46:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit87fd847f72cd039700d6a32a00ab88d41dd24379 (patch)
treeac2f3f932f05157e566623546b31cac4dc07aa20 /dev-ros/amcl/amcl-9999.ebuild
parentmail-mta/exim: add libressl support (diff)
downloadgentoo-87fd847f72cd039700d6a32a00ab88d41dd24379.tar.gz
gentoo-87fd847f72cd039700d6a32a00ab88d41dd24379.tar.bz2
gentoo-87fd847f72cd039700d6a32a00ab88d41dd24379.zip
dev-ros/amcl: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/amcl/amcl-9999.ebuild')
-rw-r--r--dev-ros/amcl/amcl-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/amcl/amcl-9999.ebuild b/dev-ros/amcl/amcl-9999.ebuild
new file mode 100644
index 000000000000..a9c2fc0e40f4
--- /dev/null
+++ b/dev-ros/amcl/amcl-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Probabilistic localization system for a robot moving in 2D"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+"