summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 17:47:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 11:41:59 +0100
commit021213baa06fdefc7d926c881ac45faf2f729a10 (patch)
tree882aee3b893b499505b3fe7716c05f1491bd4796 /dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild
parentdev-python/ament_package: initial import (diff)
downloadgentoo-021213baa06fdefc7d926c881ac45faf2f729a10.tar.gz
gentoo-021213baa06fdefc7d926c881ac45faf2f729a10.tar.bz2
gentoo-021213baa06fdefc7d926c881ac45faf2f729a10.zip
dev-ros/ament_cmake_core: initial import
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild')
-rw-r--r--dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild b/dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild
new file mode 100644
index 000000000000..da964f372122
--- /dev/null
+++ b/dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+DESCRIPTION="The core of the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}