summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 13:09:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:36 +0200
commite672f6663f5e91598dd99b04530475ace03fc8b4 (patch)
tree6ecd27899d51195d8c15851ab8bdba58401eaa51 /dev-ros/ament_cmake_export_dependencies/ament_cmake_export_dependencies-0.9.6.ebuild
parentdev-ros/ament_cmake_export_definitions: Remove old (diff)
downloadgentoo-e672f6663f5e91598dd99b04530475ace03fc8b4.tar.gz
gentoo-e672f6663f5e91598dd99b04530475ace03fc8b4.tar.bz2
gentoo-e672f6663f5e91598dd99b04530475ace03fc8b4.zip
dev-ros/ament_cmake_export_dependencies: bump to 0.9.6
Use cmake.eclass Add python check deps Closes: https://bugs.gentoo.org/719918 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_export_dependencies/ament_cmake_export_dependencies-0.9.6.ebuild')
-rw-r--r--dev-ros/ament_cmake_export_dependencies/ament_cmake_export_dependencies-0.9.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_export_dependencies/ament_cmake_export_dependencies-0.9.6.ebuild b/dev-ros/ament_cmake_export_dependencies/ament_cmake_export_dependencies-0.9.6.ebuild
new file mode 100644
index 000000000000..6dcea483b58f
--- /dev/null
+++ b/dev-ros/ament_cmake_export_dependencies/ament_cmake_export_dependencies-0.9.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Export dependencies to downstream packages in the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_libraries
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}