summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-06 10:29:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-06 11:30:46 +0200
commit65d11f3ed7703b246bb5af20f4da714090d3b4e4 (patch)
tree7904b810a161fa101e13d6c7dba06c53bb97011c /dev-ros/ament_cmake_export_include_directories/ament_cmake_export_include_directories-1.1.3.ebuild
parentdev-ros/ament_cmake_export_dependencies: bump to 1.1.3 (diff)
downloadgentoo-65d11f3ed7703b246bb5af20f4da714090d3b4e4.tar.gz
gentoo-65d11f3ed7703b246bb5af20f4da714090d3b4e4.tar.bz2
gentoo-65d11f3ed7703b246bb5af20f4da714090d3b4e4.zip
dev-ros/ament_cmake_export_include_directories: bump to 1.1.3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_export_include_directories/ament_cmake_export_include_directories-1.1.3.ebuild')
-rw-r--r--dev-ros/ament_cmake_export_include_directories/ament_cmake_export_include_directories-1.1.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_export_include_directories/ament_cmake_export_include_directories-1.1.3.ebuild b/dev-ros/ament_cmake_export_include_directories/ament_cmake_export_include_directories-1.1.3.ebuild
new file mode 100644
index 000000000000..2745da488293
--- /dev/null
+++ b/dev-ros/ament_cmake_export_include_directories/ament_cmake_export_include_directories-1.1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Export include directories to downstream packages in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}