summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-06 10:30:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-06 11:30:47 +0200
commit04abf307553a4c3931f64714dc32de6c7ec47848 (patch)
treedf4a7a46040bec9f2629aaf120bf7b478fd36c7d /dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.1.3.ebuild
parentdev-ros/ament_cmake_export_targets: bump to 1.1.3 (diff)
downloadgentoo-04abf307553a4c3931f64714dc32de6c7ec47848.tar.gz
gentoo-04abf307553a4c3931f64714dc32de6c7ec47848.tar.bz2
gentoo-04abf307553a4c3931f64714dc32de6c7ec47848.zip
dev-ros/ament_cmake_gmock: bump to 1.1.3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.1.3.ebuild')
-rw-r--r--dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.1.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.1.3.ebuild b/dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.1.3.ebuild
new file mode 100644
index 000000000000..385f6a48ae40
--- /dev/null
+++ b/dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add Google mock-based tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}