summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 12:49:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 13:09:21 +0200
commit407a52412e455ef3e945fbac7b8eb238eec377fc (patch)
tree7b7d1e8bc1fdc2b37494051b0378f9a6764404d1 /dev-ros/ament_cmake_gmock
parentdev-ros/ament_cmake_export_targets: bump to 1.0.1 (diff)
downloadgentoo-407a52412e455ef3e945fbac7b8eb238eec377fc.tar.gz
gentoo-407a52412e455ef3e945fbac7b8eb238eec377fc.tar.bz2
gentoo-407a52412e455ef3e945fbac7b8eb238eec377fc.zip
dev-ros/ament_cmake_gmock: bump to 1.0.1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_gmock')
-rw-r--r--dev-ros/ament_cmake_gmock/Manifest1
-rw-r--r--dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_gmock/Manifest b/dev-ros/ament_cmake_gmock/Manifest
index c2d6174e0c59..56fccc8713e1 100644
--- a/dev-ros/ament_cmake_gmock/Manifest
+++ b/dev-ros/ament_cmake_gmock/Manifest
@@ -1 +1,2 @@
DIST ament_cmake-1.0.0.tar.gz 63304 BLAKE2B dd0c4bc5b72d9143cfb8ee9caae236a3608981ee8523e879ea9c168d64fd1d0cb84e54679cfc0cfc58ffff34519bb1032afc956c3130c1da8b4f98d60a9191be SHA512 69236015368df29a128eceeb64dd1c683eb32a44188b52120592238f999be8c8c7c5892a36ddcef48b6686bf97eba77e820ca3b8896c64ec1522661fa3ed4fc7
+DIST ament_cmake-1.0.1.tar.gz 66465 BLAKE2B cd905b52f4600ccf364ab8d5e4dcf102e1f6034bae7ab020022860fa440ff058a996752cbb0e743b5f66a2b6bc0d1f46cec7c71900be53f035ed8a0642e50b04 SHA512 5f60c933c0ba1eea97f2d0913e19f383e154f26a0625ea4e40c529dd1fa5831109f7cbc0c39a514d37334d61c5d614df0ea546e49ab46202002af09a2adf6288
diff --git a/dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.0.1.ebuild b/dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.0.1.ebuild
new file mode 100644
index 000000000000..f63ad218898c
--- /dev/null
+++ b/dev-ros/ament_cmake_gmock/ament_cmake_gmock-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add Google mock-based tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}