summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 18:39:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 20:06:02 +0200
commite91453b72643766aa2c1d6742d54a7ac62a50fd8 (patch)
tree699ca819360c81fbab0dfcabc092195d1e70fee3 /dev-ros/ament_cmake_include_directories/ament_cmake_include_directories-1.0.0.ebuild
parentdev-ros/ament_cmake_gtest: bump to 1.0.0 (diff)
downloadgentoo-e91453b72643766aa2c1d6742d54a7ac62a50fd8.tar.gz
gentoo-e91453b72643766aa2c1d6742d54a7ac62a50fd8.tar.bz2
gentoo-e91453b72643766aa2c1d6742d54a7ac62a50fd8.zip
dev-ros/ament_cmake_include_directories: bump to 1.0.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_include_directories/ament_cmake_include_directories-1.0.0.ebuild')
-rw-r--r--dev-ros/ament_cmake_include_directories/ament_cmake_include_directories-1.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_include_directories/ament_cmake_include_directories-1.0.0.ebuild b/dev-ros/ament_cmake_include_directories/ament_cmake_include_directories-1.0.0.ebuild
new file mode 100644
index 000000000000..64cff4ebe537
--- /dev/null
+++ b/dev-ros/ament_cmake_include_directories/ament_cmake_include_directories-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Export include directories to downstream packages in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}