summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:28:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:28:24 +0300
commit554f2e44a7affb46b2d96d4cc52f8e8d1c5cc5ae (patch)
treed42bf66bf2ea5b5341de855a8611f5da67a222ea /dev-ros/ament_cmake_ros
parentdev-ros/ament_cmake_version: use python_has_version inside python_check_deps (diff)
downloadgentoo-554f2e44a7affb46b2d96d4cc52f8e8d1c5cc5ae.tar.gz
gentoo-554f2e44a7affb46b2d96d4cc52f8e8d1c5cc5ae.tar.bz2
gentoo-554f2e44a7affb46b2d96d4cc52f8e8d1c5cc5ae.zip
dev-ros/ament_cmake_ros: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_ros')
-rw-r--r--dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild2
-rw-r--r--dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild b/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild
index 5a06cfb3c18e..35af72b0cbd8 100644
--- a/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild
+++ b/dev-ros/ament_cmake_ros/ament_cmake_ros-0.10.0.ebuild
@@ -35,7 +35,7 @@ BDEPEND="
"
python_check_deps() {
- has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+ python_has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
}
src_configure() {
diff --git a/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild b/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
index 9db04e1784f0..35af72b0cbd8 100644
--- a/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
+++ b/dev-ros/ament_cmake_ros/ament_cmake_ros-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,7 +35,7 @@ BDEPEND="
"
python_check_deps() {
- has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+ python_has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
}
src_configure() {