summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-15 17:20:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-15 17:22:34 +0100
commit982808649b2b4db878af0106cacbb13b54f911fc (patch)
treeca0196f884c281f90aa9372c57e20d28e317ef7b /dev-ros/ament_cmake_test/ament_cmake_test-0.9.6.ebuild
parentdev-ros/ament_cmake_target_dependencies: Remove old (diff)
downloadgentoo-982808649b2b4db878af0106cacbb13b54f911fc.tar.gz
gentoo-982808649b2b4db878af0106cacbb13b54f911fc.tar.bz2
gentoo-982808649b2b4db878af0106cacbb13b54f911fc.zip
dev-ros/ament_cmake_test: Remove old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_test/ament_cmake_test-0.9.6.ebuild')
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-0.9.6.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-0.9.6.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-0.9.6.ebuild
deleted file mode 100644
index bb59c0de949c..000000000000
--- a/dev-ros/ament_cmake_test/ament_cmake_test-0.9.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-
-inherit cmake python-r1
-
-ROS_PN="ament_cmake"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to add tests in the ament buildsystem"
-HOMEPAGE="https://github.com/ament/ament_cmake"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-DEPEND="
- dev-ros/ament_cmake_core
- dev-python/ament_package[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-ros/ament_cmake_python
- ${PYTHON_DEPS}
-"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- python_foreach_impl cmake_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake_src_compile
-}
-
-src_test() {
- python_foreach_impl cmake_src_test
-}
-
-src_install() {
- python_foreach_impl cmake_src_install
- python_foreach_impl python_optimize
-}