summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-26 16:51:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-26 16:56:12 +0100
commit4fbf54a24a148e58a31ae6b664d7433128164a43 (patch)
tree558d30b4bfff6e0800635d75cbc7679765a56180 /dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.10.1.ebuild
parentdev-ros/ament_uncrustify: bump to 0.10.1 (diff)
downloadgentoo-4fbf54a24a148e58a31ae6b664d7433128164a43.tar.gz
gentoo-4fbf54a24a148e58a31ae6b664d7433128164a43.tar.bz2
gentoo-4fbf54a24a148e58a31ae6b664d7433128164a43.zip
dev-ros/ament_cmake_uncrustify: bump to 0.10.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.10.1.ebuild')
-rw-r--r--dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.10.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.10.1.ebuild b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.10.1.ebuild
new file mode 100644
index 000000000000..ac77dc9fa08f
--- /dev/null
+++ b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.10.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The CMake API for ament_uncrustify to check code against styleconventions"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ros/ament_cmake_test
+ dev-ros/ament_uncrustify
+"
+DEPEND=""
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ dev-ros/ament_cmake_test
+ dev-ros/ament_cmake_core
+ test? (
+ dev-ros/ament_cmake_copyright
+ $(python_gen_any_dep 'dev-ros/ament_copyright[${PYTHON_USEDEP}]')
+ dev-ros/ament_cmake_lint_cmake
+ )
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ { use !test || has_version -b "dev-ros/ament_copyright[${PYTHON_USEDEP}]"; } && \
+ has_version -b "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \
+ has_version -b "dev-python/ament_package[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}