summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-27 15:01:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-27 15:19:43 +0200
commitaf521f6d2c365ec981930b8ac3127f506655b792 (patch)
tree1933d7798fb629ac74267d73183ebea8c425bad3 /dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild
parentdev-python/pipenv: Fix src_prepare (diff)
downloadgentoo-af521f6d2c365ec981930b8ac3127f506655b792.tar.gz
gentoo-af521f6d2c365ec981930b8ac3127f506655b792.tar.bz2
gentoo-af521f6d2c365ec981930b8ac3127f506655b792.zip
dev-ros/ament_cmake_xmllint: dont build tests when not needed
Closes: https://bugs.gentoo.org/734082 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild')
-rw-r--r--dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild b/dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild
index c340183a9e6b..065d1257e262 100644
--- a/dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild
+++ b/dev-ros/ament_cmake_xmllint/ament_cmake_xmllint-9999.ebuild
@@ -52,3 +52,10 @@ python_check_deps() {
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]" && \
has_version "dev-ros/ament_xmllint[${PYTHON_USEDEP}]"
}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}