summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-04 13:18:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-05 13:31:51 +0200
commit149eb0324b5ae67a3e485504446b9cad6ef29a68 (patch)
tree424b70a6d9efc18f04eb2c54608fec5436e0aa4b /dev-ros/ament_cpplint
parentdev-ros/ament_cmake_cppcheck: bump to 0.11.2 (diff)
downloadgentoo-149eb0324b5ae67a3e485504446b9cad6ef29a68.tar.gz
gentoo-149eb0324b5ae67a3e485504446b9cad6ef29a68.tar.bz2
gentoo-149eb0324b5ae67a3e485504446b9cad6ef29a68.zip
dev-ros/ament_cpplint: bump to 0.11.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cpplint')
-rw-r--r--dev-ros/ament_cpplint/Manifest1
-rw-r--r--dev-ros/ament_cpplint/ament_cpplint-0.11.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_cpplint/Manifest b/dev-ros/ament_cpplint/Manifest
index 7ae1c97b2996..237d6ef562b9 100644
--- a/dev-ros/ament_cpplint/Manifest
+++ b/dev-ros/ament_cpplint/Manifest
@@ -1,3 +1,4 @@
DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
DIST ament_lint-0.10.1.tar.gz 221215 BLAKE2B 47ffa7dfd892b05f345ba962c7c08dcf1627c4653cc75e1a1d1cad28971974ef5ca9c09d3989b3fdbfacd7f94dace9651c44911cd7747f39c5c59083f0195443 SHA512 1dd996d86cfb7488bd6bf57510eb5b7531fe4fe21d25203a4801046ec719ba19afdb89eb7ba9d862317d2e041e7139fadde27d114614d96741a177e8ec2a2ba3
DIST ament_lint-0.10.4.tar.gz 222285 BLAKE2B 81a15dc996bad0fe3fa461aa7067eba423550d94a04881a12c8a4b0732a4a0ddcc30ab6bef94f81cb236836d8de7959b53d5560d5fb6eb480f2fbd849bd02489 SHA512 cb99084622f598b17f1ffe55620c9c822867771f2603e673098f8943d95b7be188e25480d4e22bf7c2988e94d8b69f6f7fa3b60cd042213f6bd8c2ad2c5deaf3
+DIST ament_lint-0.11.2.tar.gz 265435 BLAKE2B 09545bd029dc692e5393983a3fc9210600c4a6456635238b7038ff87799f9cfde9c2d3c7ceb4c01b71594ba7bd159e8b6b3c2370bdfcdbf3d6189a895b96292a SHA512 1a379f4fb0ead306a668aef2b9e390728d6d3901b75f43fac6ccc28681a8010e42b094237f3f1ab95ca304ba917c8fb5d5519ec0581cadb346e6eb05466e39f0
diff --git a/dev-ros/ament_cpplint/ament_cpplint-0.11.2.ebuild b/dev-ros/ament_cpplint/ament_cpplint-0.11.2.ebuild
new file mode 100644
index 000000000000..c8856b376bb5
--- /dev/null
+++ b/dev-ros/ament_cpplint/ament_cpplint-0.11.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against the Google style conventions using cpplint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest