summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-04 13:17:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-05 13:31:46 +0200
commitb7d55acb065d7fb8eeae5c761dd84180ebb11d11 (patch)
tree250753c0251709cd8ab2ef73c605dc866f653b48 /dev-ros/ament_lint/ament_lint-0.11.2.ebuild
parentdev-ros/ament_cmake_copyright: bump to 0.11.2 (diff)
downloadgentoo-b7d55acb065d7fb8eeae5c761dd84180ebb11d11.tar.gz
gentoo-b7d55acb065d7fb8eeae5c761dd84180ebb11d11.tar.bz2
gentoo-b7d55acb065d7fb8eeae5c761dd84180ebb11d11.zip
dev-ros/ament_lint: bump to 0.11.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_lint/ament_lint-0.11.2.ebuild')
-rw-r--r--dev-ros/ament_lint/ament_lint-0.11.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/ament_lint/ament_lint-0.11.2.ebuild b/dev-ros/ament_lint/ament_lint-0.11.2.ebuild
new file mode 100644
index 000000000000..8c8bff8aecc0
--- /dev/null
+++ b/dev-ros/ament_lint/ament_lint-0.11.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Common API for ament linter packages"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND=""
+# pytest.ini is there but no tests are ran causing it to fail
+RESTRICT="test"
+
+distutils_enable_tests pytest