summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 12:59:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 13:09:27 +0200
commit76e53fdf5d4e574c97a57ed26f13898625c8be75 (patch)
treead39a11e74afd96ea121dd3c72d1a579279946e3 /dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
parentdev-ros/ament_flake8: bump to 0.10.0 (diff)
downloadgentoo-76e53fdf5d4e574c97a57ed26f13898625c8be75.tar.gz
gentoo-76e53fdf5d4e574c97a57ed26f13898625c8be75.tar.bz2
gentoo-76e53fdf5d4e574c97a57ed26f13898625c8be75.zip
dev-ros/ament_lint_auto: bump to 0.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild')
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
new file mode 100644
index 000000000000..120c90db0dd4
--- /dev/null
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The auto-magic functions for ease to use of the ament linters"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_test
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}