summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 12:59:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 13:09:27 +0200
commit48354f58511af9b1f933b608a97cdd4627914896 (patch)
treebcfee34075404f3726419cf3f907eba3725104f5 /dev-ros/ament_pep257/ament_pep257-0.10.0.ebuild
parentdev-ros/ament_copyright: bump to 0.10.0 (diff)
downloadgentoo-48354f58511af9b1f933b608a97cdd4627914896.tar.gz
gentoo-48354f58511af9b1f933b608a97cdd4627914896.tar.bz2
gentoo-48354f58511af9b1f933b608a97cdd4627914896.zip
dev-ros/ament_pep257: bump to 0.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_pep257/ament_pep257-0.10.0.ebuild')
-rw-r--r--dev-ros/ament_pep257/ament_pep257-0.10.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ros/ament_pep257/ament_pep257-0.10.0.ebuild b/dev-ros/ament_pep257/ament_pep257-0.10.0.ebuild
new file mode 100644
index 000000000000..30e3a98b66d7
--- /dev/null
+++ b/dev-ros/ament_pep257/ament_pep257-0.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Checks code against style conventions in PEP 8 and generate test result files"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-python/pydocstyle[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest