summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-15 17:29:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-15 18:05:41 +0100
commitd3657824be3e8e70a49fa71b333223eaec57b309 (patch)
tree68ea58ef7e874458a0e5bcec23179edc794c2953 /dev-ros/ament_xmllint/ament_xmllint-0.12.1.ebuild
parentdev-ros/ament_lint_cmake: bump to 0.12.1 (diff)
downloadgentoo-d3657824be3e8e70a49fa71b333223eaec57b309.tar.gz
gentoo-d3657824be3e8e70a49fa71b333223eaec57b309.tar.bz2
gentoo-d3657824be3e8e70a49fa71b333223eaec57b309.zip
dev-ros/ament_xmllint: bump to 0.12.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_xmllint/ament_xmllint-0.12.1.ebuild')
-rw-r--r--dev-ros/ament_xmllint/ament_xmllint-0.12.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/ament_xmllint/ament_xmllint-0.12.1.ebuild b/dev-ros/ament_xmllint/ament_xmllint-0.12.1.ebuild
new file mode 100644
index 000000000000..f9a852493ef1
--- /dev/null
+++ b/dev-ros/ament_xmllint/ament_xmllint-0.12.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Checks XML files like the package manifest using xmllint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest