summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-01 12:28:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-01 12:39:00 +0200
commitecb111642777080475d19b1616236da7dd980fdf (patch)
treef46768c36cb62132cad9f683fe3c2565e4415e33 /dev-ros/audio_capture/audio_capture-0.3.1.ebuild
parentdev-ros/sound_play: update deps to gst 1.0 (diff)
downloadgentoo-ecb111642777080475d19b1616236da7dd980fdf.tar.gz
gentoo-ecb111642777080475d19b1616236da7dd980fdf.tar.bz2
gentoo-ecb111642777080475d19b1616236da7dd980fdf.zip
dev-ros/audio_capture: Bump to 0.3.1.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/audio_capture/audio_capture-0.3.1.ebuild')
-rw-r--r--dev-ros/audio_capture/audio_capture-0.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/audio_capture/audio_capture-0.3.1.ebuild b/dev-ros/audio_capture/audio_capture-0.3.1.ebuild
new file mode 100644
index 000000000000..4b64400bdefb
--- /dev/null
+++ b/dev-ros/audio_capture/audio_capture-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transports audio from a source to a destination"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-plugins/gst-plugins-lame:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-base:1.0
+"