summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-10 14:50:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-10 15:19:49 +0200
commit455ee334d47aa88f2d9f7d15690a113226308135 (patch)
tree0cefb625afbf86930b4c8def608cd56e4471c65f /dev-ros/audio_play/audio_play-0.3.7.ebuild
parentdev-ros/audio_common_msgs: Bump to 0.3.7. (diff)
downloadgentoo-455ee334d47aa88f2d9f7d15690a113226308135.tar.gz
gentoo-455ee334d47aa88f2d9f7d15690a113226308135.tar.bz2
gentoo-455ee334d47aa88f2d9f7d15690a113226308135.zip
dev-ros/audio_play: Bump to 0.3.7.
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/audio_play/audio_play-0.3.7.ebuild')
-rw-r--r--dev-ros/audio_play/audio_play-0.3.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/audio_play/audio_play-0.3.7.ebuild b/dev-ros/audio_play/audio_play-0.3.7.ebuild
new file mode 100644
index 000000000000..b54dfb9a1e95
--- /dev/null
+++ b/dev-ros/audio_play/audio_play-0.3.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Outputs audio to a speaker from a source node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:1.0
+"
+DEPEND="${RDEPEND}
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+RDEPEND="${RDEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-base:1.0
+"
+BDEPEND="
+ virtual/pkgconfig
+"