summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-25 11:37:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-25 12:56:23 +0200
commit593018ffe4aeca188655afb1af1b17726ec06f46 (patch)
tree5e87aa5edbd6d7332feb5c781089c8a6d3903c0f /dev-ros/bondcpp/bondcpp-1.7.18.ebuild
parentdev-ros/bond: Bump to 1.7.18. (diff)
downloadgentoo-593018ffe4aeca188655afb1af1b17726ec06f46.tar.gz
gentoo-593018ffe4aeca188655afb1af1b17726ec06f46.tar.bz2
gentoo-593018ffe4aeca188655afb1af1b17726ec06f46.zip
dev-ros/bondcpp: Bump to 1.7.18.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/bondcpp/bondcpp-1.7.18.ebuild')
-rw-r--r--dev-ros/bondcpp/bondcpp-1.7.18.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/bondcpp/bondcpp-1.7.18.ebuild b/dev-ros/bondcpp/bondcpp-1.7.18.ebuild
new file mode 100644
index 000000000000..2aa17ab51f8e
--- /dev/null
+++ b/dev-ros/bondcpp/bondcpp-1.7.18.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond
+ dev-ros/cmake_modules
+ dev-ros/roscpp
+ dev-ros/smclib
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"