summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:14:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:14:48 +0200
commit5c92fac8d71be4643f1f456975c07af6d917d721 (patch)
tree55de59dd995e37560f95acf0bc9f4964b1ca368e /dev-ros/bondpy/bondpy-1.7.16.ebuild
parentdev-ros/bondcpp: Initial import. Ebuild by me. (diff)
downloadgentoo-5c92fac8d71be4643f1f456975c07af6d917d721.tar.gz
gentoo-5c92fac8d71be4643f1f456975c07af6d917d721.tar.bz2
gentoo-5c92fac8d71be4643f1f456975c07af6d917d721.zip
dev-ros/bondpy: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/bondpy/bondpy-1.7.16.ebuild')
-rw-r--r--dev-ros/bondpy/bondpy-1.7.16.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/bondpy/bondpy-1.7.16.ebuild b/dev-ros/bondpy/bondpy-1.7.16.ebuild
new file mode 100644
index 000000000000..abb50962dc64
--- /dev/null
+++ b/dev-ros/bondpy/bondpy-1.7.16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/smclib
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"