summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:24:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:48 +0200
commit1261867d11fb0afab3b56c1e17f8644c4682e317 (patch)
treed7671bf6a9a052e8a5990854281fc136d7a608bd /dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
parentdev-ros/amcl: convert to python-single-r1 (diff)
downloadgentoo-1261867d11fb0afab3b56c1e17f8644c4682e317.tar.gz
gentoo-1261867d11fb0afab3b56c1e17f8644c4682e317.tar.bz2
gentoo-1261867d11fb0afab3b56c1e17f8644c4682e317.zip
dev-ros/calibration_estimation: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-9999.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-9999.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
index 95df5b77cf91..804aef9eae27 100644
--- a/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
+++ b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
@@ -14,16 +14,19 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- dev-python/urdf_parser_py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/matplotlib[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "sci-libs/scipy[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/urdf_parser_py[\${PYTHON_USEDEP}]")
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"