summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-24 11:43:20 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-24 12:18:21 +0100
commit7fd406c9c16ef570d4df8412cfdaa97bcd859d43 (patch)
treee6dce6318aa7b6d265e85d8fc3596594082736e9 /dev-ros/camera_calibration/camera_calibration-1.12.16.ebuild
parentdev-ros/image_view: add dep on std_srvs (diff)
downloadgentoo-7fd406c9c16ef570d4df8412cfdaa97bcd859d43.tar.gz
gentoo-7fd406c9c16ef570d4df8412cfdaa97bcd859d43.tar.bz2
gentoo-7fd406c9c16ef570d4df8412cfdaa97bcd859d43.zip
dev-ros/camera_calibration: Bump to 1.12.16.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/camera_calibration/camera_calibration-1.12.16.ebuild')
-rw-r--r--dev-ros/camera_calibration/camera_calibration-1.12.16.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration/camera_calibration-1.12.16.ebuild b/dev-ros/camera_calibration/camera_calibration-1.12.16.ebuild
new file mode 100644
index 000000000000..417e035b19bc
--- /dev/null
+++ b/dev-ros/camera_calibration/camera_calibration-1.12.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of monocular or stereo cameras using a checkerboard calibration target"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/image_geometry[${PYTHON_USEDEP}]
+ || ( media-libs/opencv[python,${PYTHON_USEDEP}] media-libs/opencv[python,python_single_target_python2_7] )
+ dev-ros/message_filters[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"