summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 12:40:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 13:03:03 +0100
commit337db3d5dc06f2547edca15c758d6f405499b235 (patch)
tree137c424f2f658ce0b40976bab8545272af93eddf /dev-ros/camera_calibration
parentdev-ros/image_view: bump cv_bridge dep in live ebuild (diff)
downloadgentoo-337db3d5dc06f2547edca15c758d6f405499b235.tar.gz
gentoo-337db3d5dc06f2547edca15c758d6f405499b235.tar.bz2
gentoo-337db3d5dc06f2547edca15c758d6f405499b235.zip
dev-ros/camera_calibration: Bump to 1.12.15.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/camera_calibration')
-rw-r--r--dev-ros/camera_calibration/Manifest1
-rw-r--r--dev-ros/camera_calibration/camera_calibration-1.12.15.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration/Manifest b/dev-ros/camera_calibration/Manifest
index 0cc1356d6b68..cf8b7d53eb7e 100644
--- a/dev-ros/camera_calibration/Manifest
+++ b/dev-ros/camera_calibration/Manifest
@@ -1 +1,2 @@
DIST image_pipeline-1.12.14.tar.gz 118296 SHA256 8e3b756932a821b4387b7f86ca9fc5233ebb2a13541b220b866e42ea6f92b17f SHA512 724b6d20edab1436c51a05f4399b852cabab74c5e04dea97f53a256fb512b4dbfc97fd6e7d74d41bfd7d92fe183aa86a993a39b8687c27dc7b7f85d1a1c81b94 WHIRLPOOL 394343ddf299f6c7e26c0a2f45e49edc2c4047a0ccd15885a998fa902bb7373fa44181f06adc222483a285f32df800e0b268485cb2fd98e54956929056868d5d
+DIST image_pipeline-1.12.15.tar.gz 122012 SHA256 d9660a5929b69b7801b3a05e092c7a4a5543d45084c9198fdaa9c8a0210db76c SHA512 184805f99020332ad74899ec47abc56144aceef8d4eabf877a4dc85f30befdc78b209407e1be624ba151be3a71be1fafdbd87c771137bee7c080c24935f6c6fa WHIRLPOOL d9ceff4b34767e33fe8eae49076fae133dd8146c2b09fb3ce42c0c902c6d95a06cb990e5f543dfb0215a18b0592193d65c782a45301c18e4f8a34fb35e509449
diff --git a/dev-ros/camera_calibration/camera_calibration-1.12.15.ebuild b/dev-ros/camera_calibration/camera_calibration-1.12.15.ebuild
new file mode 100644
index 000000000000..417e035b19bc
--- /dev/null
+++ b/dev-ros/camera_calibration/camera_calibration-1.12.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of monocular or stereo cameras using a checkerboard calibration target"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/image_geometry[${PYTHON_USEDEP}]
+ || ( media-libs/opencv[python,${PYTHON_USEDEP}] media-libs/opencv[python,python_single_target_python2_7] )
+ dev-ros/message_filters[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"