summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 11:19:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 11:44:13 +0200
commitd1b84599732ec0a59bedfe6dc580d4bc702d5f84 (patch)
tree11dc173eaa538c70270d0498f7e64741b9f206b5 /dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
parentdev-ros/polled_camera: Initial import. Ebuild by me. (diff)
downloadgentoo-d1b84599732ec0a59bedfe6dc580d4bc702d5f84.tar.gz
gentoo-d1b84599732ec0a59bedfe6dc580d4bc702d5f84.tar.bz2
gentoo-d1b84599732ec0a59bedfe6dc580d4bc702d5f84.zip
dev-ros/camera_calibration_parsers: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild')
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
new file mode 100644
index 000000000000..e9cd4e2e33de
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-ros/rosconsole
+ >=dev-cpp/yaml-cpp-0.5
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/nose )
+"