summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 17:23:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:14 +0100
commit3f6239644a3340cdfd988fab20b5ea4710a5bec3 (patch)
tree7f5e683d576c701c44b7dc7beb32971f0a40a2c2 /dev-ros/carrot_planner/carrot_planner-1.15.1-r1.ebuild
parentsci-electronics/gazebo: fix build with tinyxml2-6 (diff)
downloadgentoo-3f6239644a3340cdfd988fab20b5ea4710a5bec3.tar.gz
gentoo-3f6239644a3340cdfd988fab20b5ea4710a5bec3.tar.bz2
gentoo-3f6239644a3340cdfd988fab20b5ea4710a5bec3.zip
dev-ros/carrot_planner: add missing := dep on console_bridge
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/carrot_planner/carrot_planner-1.15.1-r1.ebuild')
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.15.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/carrot_planner-1.15.1-r1.ebuild b/dev-ros/carrot_planner/carrot_planner-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..e3dc1d771531
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.15.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/base_local_planner
+ dev-ros/pluginlib
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"