summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-31 13:24:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-31 15:09:10 +0200
commit5ae7c050f5cca66daf87f7f5cca39c5f50173077 (patch)
treebc6a55b53edb5d6a86883b897320cbdf74d6494e /dev-ros/carrot_planner/carrot_planner-1.16.1.ebuild
parentdev-ros/base_local_planner: Bump to 1.16.1. (diff)
downloadgentoo-5ae7c050f5cca66daf87f7f5cca39c5f50173077.tar.gz
gentoo-5ae7c050f5cca66daf87f7f5cca39c5f50173077.tar.bz2
gentoo-5ae7c050f5cca66daf87f7f5cca39c5f50173077.zip
dev-ros/carrot_planner: Bump to 1.16.1.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/carrot_planner/carrot_planner-1.16.1.ebuild')
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.16.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/carrot_planner-1.16.1.ebuild b/dev-ros/carrot_planner/carrot_planner-1.16.1.ebuild
new file mode 100644
index 000000000000..9b88284f1191
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.16.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"