summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:28:44 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 17:12:23 +0100
commitf9d2efb3107b603a233f12f59e54ec627b556f8a (patch)
treed61e6727f69c44b99f4e5d721881f8491853dd75 /dev-ros/carrot_planner/carrot_planner-1.16.3.ebuild
parentdev-ros/base_local_planner: Bump to 1.16.3. (diff)
downloadgentoo-f9d2efb3107b603a233f12f59e54ec627b556f8a.tar.gz
gentoo-f9d2efb3107b603a233f12f59e54ec627b556f8a.tar.bz2
gentoo-f9d2efb3107b603a233f12f59e54ec627b556f8a.zip
dev-ros/carrot_planner: Bump to 1.16.3.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/carrot_planner/carrot_planner-1.16.3.ebuild')
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.16.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/carrot_planner-1.16.3.ebuild b/dev-ros/carrot_planner/carrot_planner-1.16.3.ebuild
new file mode 100644
index 000000000000..a1772a73b786
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.16.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"