summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 15:55:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:40 +0200
commit5ec6fb1e5797025f3a949f70df5b7da339c6ee91 (patch)
tree64e99df96b92fe0cf0667ea12ef99840a26d7e8e /dev-ros/carrot_planner/carrot_planner-1.17.0-r1.ebuild
parentdev-ros/qt_gui_cpp: fix build (diff)
downloadgentoo-5ec6fb1e5797025f3a949f70df5b7da339c6ee91.tar.gz
gentoo-5ec6fb1e5797025f3a949f70df5b7da339c6ee91.tar.bz2
gentoo-5ec6fb1e5797025f3a949f70df5b7da339c6ee91.zip
dev-ros/carrot_planner: add := dep on cbridge
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/carrot_planner/carrot_planner-1.17.0-r1.ebuild')
-rw-r--r--dev-ros/carrot_planner/carrot_planner-1.17.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/carrot_planner-1.17.0-r1.ebuild b/dev-ros/carrot_planner/carrot_planner-1.17.0-r1.ebuild
new file mode 100644
index 000000000000..988e46d33c04
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-1.17.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_ros
+
+ dev-libs/console_bridge:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"