summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-28 16:53:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-28 17:21:47 +0200
commitaa65261e214f17b7572d14fc05b921130ff25b9c (patch)
tree3c738d39dc4a8cdc88008471559ccd152c160ac5 /dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.2.ebuild
parentdev-ros/combined_robot_hw: Bump to 0.14.2. (diff)
downloadgentoo-aa65261e214f17b7572d14fc05b921130ff25b9c.tar.gz
gentoo-aa65261e214f17b7572d14fc05b921130ff25b9c.tar.bz2
gentoo-aa65261e214f17b7572d14fc05b921130ff25b9c.zip
dev-ros/combined_robot_hw_tests: Bump to 0.14.2.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.2.ebuild')
-rw-r--r--dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.2.ebuild b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.2.ebuild
new file mode 100644
index 000000000000..e23c205a4524
--- /dev/null
+++ b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.14.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/combined_robot_hw
+ dev-ros/controller_manager
+ dev-ros/controller_manager_tests
+ dev-ros/hardware_interface
+ dev-ros/roscpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"