summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 11:48:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 12:45:52 +0200
commitc8e4bab9f024ba538462b0ff72bee8959d167223 (patch)
tree1b36ce3c2a26237671b17c38427e0033f1a18c8a /dev-ros/compressed_image_transport
parentdev-ros/compressed_image_transport: bump eapi (diff)
downloadgentoo-c8e4bab9f024ba538462b0ff72bee8959d167223.tar.gz
gentoo-c8e4bab9f024ba538462b0ff72bee8959d167223.tar.bz2
gentoo-c8e4bab9f024ba538462b0ff72bee8959d167223.zip
dev-ros/compressed_image_transport: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/compressed_image_transport')
-rw-r--r--dev-ros/compressed_image_transport/Manifest1
-rw-r--r--dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild26
-rw-r--r--dev-ros/compressed_image_transport/files/ocv4.patch22
3 files changed, 0 insertions, 49 deletions
diff --git a/dev-ros/compressed_image_transport/Manifest b/dev-ros/compressed_image_transport/Manifest
index 9162d0af9256..0065b847e9bf 100644
--- a/dev-ros/compressed_image_transport/Manifest
+++ b/dev-ros/compressed_image_transport/Manifest
@@ -1,2 +1 @@
DIST image_transport_plugins-1.14.0.tar.gz 28803 BLAKE2B fc3fc34c0dc01c5dc0ed7f2a88fd691f9b955009bbf91a2280e39455e0325a46edc67c25cf79d8e4882789c20235c13fb87bfc64669ffda40a1fe37224a346e9 SHA512 1333f18a3208ecda4f788dc2d974b5787a89d33a1ad1ea2c6b4cc07593c677686aa5e9df3346d2e5f307699b88b42f341a989eebecc3cd7885768e3dcdbbcdcb
-DIST image_transport_plugins-1.9.5.tar.gz 26268 BLAKE2B 2d7e71f891bc3ae548193a9671fb10fb4dc6c7a24fda0c0dc52d75d43793d55e35da37155496740624e4ebe34fcf0e8d3926345ca1581fa521096c01b773f551 SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c
diff --git a/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild
deleted file mode 100644
index 044d1c361210..000000000000
--- a/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Plugin to image_transport for transparently sending images encoded as JPEG or PNG"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cv_bridge
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
- dev-ros/image_transport
- >=media-libs/opencv-4:=
- dev-libs/boost:=
- dev-libs/console_bridge:=
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/ocv4.patch" )
diff --git a/dev-ros/compressed_image_transport/files/ocv4.patch b/dev-ros/compressed_image_transport/files/ocv4.patch
deleted file mode 100644
index 6b3406b5c006..000000000000
--- a/dev-ros/compressed_image_transport/files/ocv4.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: compressed_image_transport/src/compressed_publisher.cpp
-===================================================================
---- compressed_image_transport.orig/src/compressed_publisher.cpp
-+++ compressed_image_transport/src/compressed_publisher.cpp
-@@ -97,7 +97,7 @@ void CompressedPublisher::publish(const
- // JPEG Compression
- case JPEG:
- {
-- params[0] = CV_IMWRITE_JPEG_QUALITY;
-+ params[0] = cv::IMWRITE_JPEG_QUALITY;
- params[1] = config_.jpeg_quality;
-
- // Update ros message format header
-@@ -154,7 +154,7 @@ void CompressedPublisher::publish(const
- // PNG Compression
- case PNG:
- {
-- params[0] = CV_IMWRITE_PNG_COMPRESSION;
-+ params[0] = cv::IMWRITE_PNG_COMPRESSION;
- params[1] = config_.png_level;
-
- // Update ros message format header