summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 16:55:53 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 17:23:12 +0100
commitd37223c0fc8d42db7d10f7860955bb6b0426d6a5 (patch)
tree41bfc4fba3c3b1c79bd4dea090355ddc85d6aa1a /dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
parentgames-strategy/0ad: Added missing header includes (diff)
downloadgentoo-d37223c0fc8d42db7d10f7860955bb6b0426d6a5.tar.gz
gentoo-d37223c0fc8d42db7d10f7860955bb6b0426d6a5.tar.bz2
gentoo-d37223c0fc8d42db7d10f7860955bb6b0426d6a5.zip
dev-ros/console_bridge_vendor: initial import
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild')
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
new file mode 100644
index 000000000000..e36d23f50a78
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Wrapper around console_bridge"
+HOMEPAGE="https://github.com/ros2/console_bridge_vendor"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ >=dev-libs/console_bridge-0.4.1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}