summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 14:17:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:52 +0200
commit66a0e00c86c95b393c4421a3872835f8851f7edd (patch)
treef7399bba5614ea35c33cb01f88547f05f6d750c7 /dev-ros/console_bridge_vendor
parentmedia-video/ffmpeg: bump to 4.3.1 (diff)
downloadgentoo-66a0e00c86c95b393c4421a3872835f8851f7edd.tar.gz
gentoo-66a0e00c86c95b393c4421a3872835f8851f7edd.tar.bz2
gentoo-66a0e00c86c95b393c4421a3872835f8851f7edd.zip
dev-ros/console_bridge_vendor: bump to 1.2.1
Use cmake.eclass Add python check deps Closes: https://bugs.gentoo.org/708572 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/console_bridge_vendor')
-rw-r--r--dev-ros/console_bridge_vendor/Manifest1
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.1.ebuild49
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild22
3 files changed, 67 insertions, 5 deletions
diff --git a/dev-ros/console_bridge_vendor/Manifest b/dev-ros/console_bridge_vendor/Manifest
index 0855dcea071b..ad4240f4b381 100644
--- a/dev-ros/console_bridge_vendor/Manifest
+++ b/dev-ros/console_bridge_vendor/Manifest
@@ -1 +1,2 @@
DIST console_bridge_vendor-1.2.0.tar.gz 5640 BLAKE2B d0a2b18c8d4b9259e6c8ba2953a7650e9aaef348345c5651b5a769ec9c2d4346e404688d7e6c60c3c45186d0afa0e3d3a6d9e49baef2ef1da4e0679aa7d5ba06 SHA512 2b5c8ab47554d724665184ae4dfea32a6291d9d2578a489eb81e695cc513c723e934c1dca0e66eaf83b81d656fbc67a4c7e3b4d15eae5d8770ad6ebc700b6d6b
+DIST console_bridge_vendor-1.2.1.tar.gz 7403 BLAKE2B d18f2ccb352c04b1c84a2c8ed5bb4fb790cddd3adf9667a6e9e99cdfb7da3f24931c653ffd0c8175131799d08086d110ad9ad33660ffc307a3a21a7dbf54ebef SHA512 12b611ff578b4a9e20fc894789985056b1b396f7085d4d6f0848fbe1a926ddc47ee6cc2c65bf3289041573b48bad75e2ce5a6d1b3f94aa8049429faece44d6a2
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.1.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.1.ebuild
new file mode 100644
index 000000000000..41ddf98ec4ba
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Wrapper around console_bridge"
+HOMEPAGE="https://github.com/ros2/console_bridge_vendor"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/console_bridge-1.0.1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? ( dev-ros/ament_lint_auto )
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
index 9d08355634bd..41ddf98ec4ba 100644
--- a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -25,13 +25,25 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
+IUSE="test"
DEPEND="
- >=dev-libs/console_bridge-0.4.1
+ >=dev-libs/console_bridge-1.0.1
"
RDEPEND="${DEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? ( dev-ros/ament_lint_auto )
${PYTHON_DEPS}
"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}