summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 15:57:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:40 +0200
commitabbc410b6a37224397ffaa9822ee94e3ee7c5f9c (patch)
tree22adc8310197e66a34ba6f17648e27a1c6e5a784 /dev-ros/costmap_2d/costmap_2d-1.17.0-r1.ebuild
parentdev-ros/costmap_2d: use python-single-r1 dep style (diff)
downloadgentoo-abbc410b6a37224397ffaa9822ee94e3ee7c5f9c.tar.gz
gentoo-abbc410b6a37224397ffaa9822ee94e3ee7c5f9c.tar.bz2
gentoo-abbc410b6a37224397ffaa9822ee94e3ee7c5f9c.zip
dev-ros/costmap_2d: add := dep on cbridge
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/costmap_2d/costmap_2d-1.17.0-r1.ebuild')
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.17.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/costmap_2d-1.17.0-r1.ebuild b/dev-ros/costmap_2d/costmap_2d-1.17.0-r1.ebuild
new file mode 100644
index 000000000000..43498a63a280
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.17.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/voxel_grid
+
+ dev-ros/tf2_sensor_msgs
+
+ dev-cpp/eigen:3
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml2:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/map_server
+ dev-ros/rosbag
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit
+ )"
+BDEPEND="
+ dev-ros/cmake_modules
+"