summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 12:26:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit8d5cc0a64cbbf44444559c302fb5e04f3fcec658 (patch)
treec8d97876cda1f9ff722f0b6f7c807dbfc1631b37 /dev-ros/costmap_2d
parentdev-ros/voxel_grid: Initial import. Ebuild by me. (diff)
downloadgentoo-8d5cc0a64cbbf44444559c302fb5e04f3fcec658.tar.gz
gentoo-8d5cc0a64cbbf44444559c302fb5e04f3fcec658.tar.bz2
gentoo-8d5cc0a64cbbf44444559c302fb5e04f3fcec658.zip
dev-ros/costmap_2d: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/costmap_2d')
-rw-r--r--dev-ros/costmap_2d/Manifest1
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.13.0.ebuild39
-rw-r--r--dev-ros/costmap_2d/costmap_2d-9999.ebuild39
-rw-r--r--dev-ros/costmap_2d/metadata.xml5
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/Manifest b/dev-ros/costmap_2d/Manifest
new file mode 100644
index 000000000000..2ab0c74f2366
--- /dev/null
+++ b/dev-ros/costmap_2d/Manifest
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/dev-ros/costmap_2d/costmap_2d-1.13.0.ebuild b/dev-ros/costmap_2d/costmap_2d-1.13.0.ebuild
new file mode 100644
index 000000000000..3f803fb89cca
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/voxel_grid
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/costmap_2d/costmap_2d-9999.ebuild b/dev-ros/costmap_2d/costmap_2d-9999.ebuild
new file mode 100644
index 000000000000..3f803fb89cca
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/voxel_grid
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/costmap_2d/metadata.xml b/dev-ros/costmap_2d/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/costmap_2d/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>