summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 17:20:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:14 +0100
commit9bd827ed49e29a271d675c65e7b9702131711635 (patch)
treebb746ab3752dee03cc35449c89c0bf49521c1c71 /dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
parentdev-libs/console_bridge: bump to 0.4.0 (diff)
downloadgentoo-9bd827ed49e29a271d675c65e7b9702131711635.tar.gz
gentoo-9bd827ed49e29a271d675c65e7b9702131711635.tar.bz2
gentoo-9bd827ed49e29a271d675c65e7b9702131711635.zip
dev-ros/depthimage_to_laserscan: add missing := dep on console bridge
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild')
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..b0b3cce5f4e8
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" )