summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-02 12:55:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-05 11:52:01 +0200
commit05ff68a7c09066c27f4d0068ebca314419a63c01 (patch)
treed244f92d59a11a6ebf8f10c7ed482853c0510b2d /dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.4.ebuild
parentmedia-gfx/sane-backends: Drop 1.0.30-r2 (diff)
downloadgentoo-05ff68a7c09066c27f4d0068ebca314419a63c01.tar.gz
gentoo-05ff68a7c09066c27f4d0068ebca314419a63c01.tar.bz2
gentoo-05ff68a7c09066c27f4d0068ebca314419a63c01.zip
dev-ros/diagnostic_aggregator: Bump to 1.10.4.
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.4.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.4.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.4.ebuild
new file mode 100644
index 000000000000..b43991e89535
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/pluginlib:=
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}