summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-09 13:40:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-09 14:19:23 +0100
commit11d07565c5ce3e6c5a64dca8435263c69f03710a (patch)
tree7fc637f917a208ba596f05312069085c827d445a /dev-ros/diagnostic_aggregator
parentdev-ros/cv_bridge: Remove old (diff)
downloadgentoo-11d07565c5ce3e6c5a64dca8435263c69f03710a.tar.gz
gentoo-11d07565c5ce3e6c5a64dca8435263c69f03710a.tar.bz2
gentoo-11d07565c5ce3e6c5a64dca8435263c69f03710a.zip
dev-ros/diagnostic_aggregator: Bump to 1.11.0.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/diagnostic_aggregator')
-rw-r--r--dev-ros/diagnostic_aggregator/Manifest1
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.11.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/Manifest b/dev-ros/diagnostic_aggregator/Manifest
index b90ad93eec8e..872b91b81f02 100644
--- a/dev-ros/diagnostic_aggregator/Manifest
+++ b/dev-ros/diagnostic_aggregator/Manifest
@@ -2,3 +2,4 @@ DIST diagnostics-1.10.1.tar.gz 536607 BLAKE2B 6a69163fbf60820839f1fc7071b6ea9df7
DIST diagnostics-1.10.2.tar.gz 536910 BLAKE2B da4de61798d0022114573ca7360f48afe0a7b62f56ac2e9830182dfd0cdaf2f7985b549807028360d8edd97ec3630465eef0d02c51333ffedf0809f235a11f26 SHA512 5a88cfe6f2bc71ae71e3d7aad6c83c6ac17fb2e072b8ba1ba97b86cb8e6f7373ba2c4b6889d0253f062119c86459880485b1afc682747f91c2eb7acdb9e71d3c
DIST diagnostics-1.10.3.tar.gz 537295 BLAKE2B be2937c7bc537eff5c4ffd04ffcd92734626d6563c0392f645af2a6a8b2937d08157168ce12248b63316b14b5ca11e78219cb0812cf02b63c79a6cc516e080c0 SHA512 7f074f8ad789e7a07323984fa79766ae4a8ce75faf99ce31549ef97ddb2eb3b37f473878cc23557b61a0f8650582db232fe69f901c48bd2b479d42166055bcd7
DIST diagnostics-1.10.4.tar.gz 537046 BLAKE2B 944a2ba3614abc48677a000efcdbe47db95bc05adb018aa24fa4c2ce0f3e8ff21f537d94541f29947a3eb10d71012abed5f5f9049290d0a6242812ade73c780a SHA512 14aa086f5341dfb3cea8697350a79b863fba870255cb057dcd7019a32e69ed42d7c66d6ee209f65fb94875cf63001f785093da913b1a47b4a183c21c9c775d40
+DIST diagnostics-1.11.0.tar.gz 538022 BLAKE2B 6d6a4c17af1080d77786f5894ca3bd5c2e39e912529aee813f1e7fede4e8265e2dc0e4b3cd09051dd9456227e4db35d24fa3eebc83f77e15ba5af3bdf169df5e SHA512 c1cb328498e45211620c4d8cd025e6d1ec4c71d853b83d7f2eb0673619c70e4a96911e60c5caa6f80298cbba93769243d07c41713972546425fbe94f8ddc8f60
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.11.0.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.11.0.ebuild
new file mode 100644
index 000000000000..6d2eff254e5e
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/pluginlib:=
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}