summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-28 16:05:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-28 16:35:39 +0200
commitf4b13b1ba8279204e4eb69b50e43979a58c6ef0d (patch)
treef4232c0864ed158fadf7a227a1363e6dca184cee /dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.10.ebuild
parentdev-ros/diagnostic_aggregator: Bump to 1.8.10. (diff)
downloadgentoo-f4b13b1ba8279204e4eb69b50e43979a58c6ef0d.tar.gz
gentoo-f4b13b1ba8279204e4eb69b50e43979a58c6ef0d.tar.bz2
gentoo-f4b13b1ba8279204e4eb69b50e43979a58c6ef0d.zip
dev-ros/diagnostic_analysis: Bump to 1.8.10.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.10.ebuild')
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.10.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.10.ebuild
new file mode 100644
index 000000000000..b1f5d73a22a8
--- /dev/null
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts diagnostics data into a series of CSV files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"