summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-05 12:53:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-05 12:58:32 +0100
commit400f8f19e1b17c24aeb02ac157c099c8dfa8a5ee (patch)
tree8e3092b526d1a54980d23a8c268422e6520eef94 /dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.9.ebuild
parentdev-ros/diagnostic_aggregator: Bump to 1.8.9. (diff)
downloadgentoo-400f8f19e1b17c24aeb02ac157c099c8dfa8a5ee.tar.gz
gentoo-400f8f19e1b17c24aeb02ac157c099c8dfa8a5ee.tar.bz2
gentoo-400f8f19e1b17c24aeb02ac157c099c8dfa8a5ee.zip
dev-ros/diagnostic_analysis: Bump to 1.8.9.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.9.ebuild')
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.9.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.9.ebuild
new file mode 100644
index 000000000000..083a528ce6f2
--- /dev/null
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.8.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts diagnostics data into a series of CSV files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"