summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:58:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:25 +0200
commit71d5adffead4dc6225d52773216884cce8341ddc (patch)
tree263cbe1f200dd5ae101f4b144cde35b751d35192 /dev-ros/diagnostic_updater/diagnostic_updater-1.8.8.ebuild
parentdev-ros/tf: Initial import. Ebuild by me. (diff)
downloadgentoo-71d5adffead4dc6225d52773216884cce8341ddc.tar.gz
gentoo-71d5adffead4dc6225d52773216884cce8341ddc.tar.bz2
gentoo-71d5adffead4dc6225d52773216884cce8341ddc.zip
dev-ros/diagnostic_updater: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/diagnostic_updater/diagnostic_updater-1.8.8.ebuild')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-1.8.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-1.8.8.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-1.8.8.ebuild
new file mode 100644
index 000000000000..042be479d1cc
--- /dev/null
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-1.8.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for updating diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"