summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-08 14:15:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-08 14:22:25 +0200
commit4af45f09d46c548edc35b3dcb95e6749a22e47ab (patch)
treebdc1ec4516e5f39558e66ed2191c353a95b92f2e /dev-ros/diagnostic_updater/diagnostic_updater-1.9.3.ebuild
parentdev-ros/diagnostic_common_diagnostics: Bump to 1.9.3. (diff)
downloadgentoo-4af45f09d46c548edc35b3dcb95e6749a22e47ab.tar.gz
gentoo-4af45f09d46c548edc35b3dcb95e6749a22e47ab.tar.bz2
gentoo-4af45f09d46c548edc35b3dcb95e6749a22e47ab.zip
dev-ros/diagnostic_updater: Bump to 1.9.3.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/diagnostic_updater/diagnostic_updater-1.9.3.ebuild')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-1.9.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.3.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.3.ebuild
new file mode 100644
index 000000000000..961c2bf53258
--- /dev/null
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for updating diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"