summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-27 11:08:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-27 11:26:00 +0200
commitfe3ffa03ffcab3db9ec022437fb97eaa1c527b04 (patch)
tree070e446ae21ed5547eeb68b860079d5b5d7b9fd8 /dev-ros/dwa_local_planner/dwa_local_planner-1.16.0.ebuild
parentdev-ros/costmap_2d: Bump to 1.16.0. (diff)
downloadgentoo-fe3ffa03ffcab3db9ec022437fb97eaa1c527b04.tar.gz
gentoo-fe3ffa03ffcab3db9ec022437fb97eaa1c527b04.tar.bz2
gentoo-fe3ffa03ffcab3db9ec022437fb97eaa1c527b04.zip
dev-ros/dwa_local_planner: Bump to 1.16.0.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ros/dwa_local_planner/dwa_local_planner-1.16.0.ebuild')
-rw-r--r--dev-ros/dwa_local_planner/dwa_local_planner-1.16.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/dwa_local_planner/dwa_local_planner-1.16.0.ebuild b/dev-ros/dwa_local_planner/dwa_local_planner-1.16.0.ebuild
new file mode 100644
index 000000000000..16fd4d5bf38e
--- /dev/null
+++ b/dev-ros/dwa_local_planner/dwa_local_planner-1.16.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Dynamic Window Approach to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"